[Openstack] [Swift] Unexplained 404s

John Dickinson me at not.mn
Fri May 20 18:16:17 UTC 2016

On 20 May 2016, at 10:27, Shrinand Javadekar wrote:

> Hi,
> I am troubleshooting a test setup where Swift returned a 201 for
> objects that were put in it but later when I tried to read it, I got
> back 404s.
> The system has been under load. I see lots of connection errors,
> lock-timeouts, etc. However, I am not sure if ever Swift should be
> returning a 404.
> I tried simulating some of these on a different setup and always got
> the expected response (which wasn't a 404).
> - Stopped memcached and did a blob get. This returned a 401 Unauthorized error.
> - Stopped the object-server and did a blob get. This returned a 503
> internal server error.
> - Stopped the container-server. This didn't have any effect. The
> container-server is not looked during every GET.
> - Stopped the account-server. Same result as container-server.
> Any ideas on when Swift might return a 404 even though the object was
> successfully written?
> Thanks in advance.
> -Shri

Use `swift-get-nodes` to see where Swift thinks the object is in the cluster, then check those drives for the data. If the data is actually on disk, then the issue is either mis-deployed ring files or possibly the timeouts you mentioned.

If the data isn't on disk, then check your logs for every mention of the object you're looking for to see if it was deleted. Also check the other drives in the cluster for the object to see if it's there (capacity adjustments or failures can result in data being put in other places in the cluster).


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: OpenPGP digital signature
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20160520/92ace66a/attachment.sig>

More information about the Openstack mailing list