[Openstack] [Swift] Unexplained 404s

Mark Kirkwood mark.kirkwood at catalyst.net.nz
Fri May 20 23:53:22 UTC 2016

On 21/05/16 05:27, Shrinand Javadekar wrote:
> Hi,
> I am troubleshooting a test setup where Swift returned a 201 for
> objects that were put in it but later when I tried to read it, I got
> back 404s.
> The system has been under load. I see lots of connection errors,
> lock-timeouts, etc. However, I am not sure if ever Swift should be
> returning a 404.
> I tried simulating some of these on a different setup and always got
> the expected response (which wasn't a 404).
> - Stopped memcached and did a blob get. This returned a 401 Unauthorized error.
> - Stopped the object-server and did a blob get. This returned a 503
> internal server error.
> - Stopped the container-server. This didn't have any effect. The
> container-server is not looked during every GET.
> - Stopped the account-server. Same result as container-server.
> Any ideas on when Swift might return a 404 even though the object was
> successfully written?

I addition to what John said, I've seen that sort of behaviour on slow 
or heavily loaded systems (e.g):

- write an object (successful)
- immediately try to read it (404)
- a few minutes later try to read it (successful)

This is because the replication step can take some time to place the 
object on all the devices where it is supposed to live (i.e a read may 
not always look at where the object has just been written).



More information about the Openstack mailing list