python_requires >= 3.8 during Yoga

Sean Mooney smooney at
Thu Nov 25 18:48:37 UTC 2021

On Thu, 2021-11-25 at 18:13 +0000, Stephen Finucane wrote:
> gmann has been helpfully proposing patches to change the versions of Python
> we're testing against in Yoga. I've suggested that we might want to bump
> 'python_requires' in 'setup.cfg' to indicate that we no longer support any
> version of Python before 3.8 [1]. As gmann has noted, doing so would mean nova
> would no longer be installable on Python 3.6 or 3.7 and there has been a small
> bit of back and forth on the pros and cons of this. I'm wondering what other
> people's thoughts on this are. Is this something we should be doing? Should we
> do it for libraries too or just services? Do we ever want to do this? Thoughts,
> please!

so i was advocating for dropping supprot for python below 3.8 this cycle so i woudl be at least
in favor of offilly not supprot less then 3.8

in terms of if wew shoudl add python_requries >= 3.8 to project im a littel less certin

i think loss of 3.6 support is effectigly goign to happen via uages of 3.7 and 3.8 only feature anyway.

there are a number of feature in python 3.8 vs 3.7 and 3.6

there are also a number of thing that are removed in 3.9 and 3.10

i have not check all of those to determin if we will be impacted by those changes or not
but if we look at the end of life of the various python releases 3.6 is nolonger supppred for security updates
from (23 Dec 2021) so i think we shoudl at least increase to 3.7

i woudl prefer to update to 3.8 which would (14 Oct 2024)

that would mean we are testing with a python that is security supproted for the lifetime of the stable yoga branch and byond.

> Stephen
> [1]

More information about the openstack-discuss mailing list