python_requires >= 3.8 during Yoga

Stephen Finucane stephenfin at
Thu Nov 25 18:13:10 UTC 2021

gmann has been helpfully proposing patches to change the versions of Python
we're testing against in Yoga. I've suggested that we might want to bump
'python_requires' in 'setup.cfg' to indicate that we no longer support any
version of Python before 3.8 [1]. As gmann has noted, doing so would mean nova
would no longer be installable on Python 3.6 or 3.7 and there has been a small
bit of back and forth on the pros and cons of this. I'm wondering what other
people's thoughts on this are. Is this something we should be doing? Should we
do it for libraries too or just services? Do we ever want to do this? Thoughts,



More information about the openstack-discuss mailing list