[openstack-dev] [Neutron][policy] Group Based Policy - Renaming

Jay Pipes jaypipes at gmail.com
Fri Aug 8 15:43:16 UTC 2014

On 08/07/2014 01:17 PM, Ronak Shah wrote:
> Hi,
> Following a very interesting and vocal thread on GBP for last couple of
> days and the GBP meeting today, GBP sub-team proposes following name
> changes to the resource.
> policy-point for endpoint
> policy-group for endpointgroup (epg)
> Please reply if you feel that it is not ok with reason and suggestion.

Thanks Ronak and Sumit for sharing. I, too, wasn't able to attend the 
meeting (was in other meetings yesterday and today).

I'm very happy with the change from endpoint-group -> policy-group.

policy-point is better than endpoint, for sure. The only other 
suggestion I might have would be to use "policy-target" instead of 
"policy-point", since the former clearly delineates what the object is 
used for (a target for a policy).

But... I won't raise a stink about this. Sorry for sparking long and 
tangential discussions on GBP topics earlier this week. And thanks to 
the folks who persevered and didn't take too much offense to my questioning.


More information about the OpenStack-dev mailing list