[openstack-dev] [Neutron][oslo] Problem installing oslo.config- from .whl files

Alexei Kornienko alexei.kornienko at gmail.com
Tue Aug 5 20:08:45 UTC 2014

Hello Carl,

You should try to update your virtualenv (pip install -U virtualenv).
It fixed this problem for me.


On 05/08/14 23:00, Carl Baldwin wrote:
> Hi,
> I noticed this yesterday afternoon.  I tried to run pep8 and unit
> tests on a patch I was going to submit.  It failed with an error that
> no package satisfying oslo.config could be found [1].  I went to pypi
> and saw that the version appears to be available [2] but still
> couldn't install it.
> I tried to activate the .tox/pep8 virtual environment and install the
> version explicitly.  Interestingly, that worked in one gerrit repo for
> Neutron [3] but not the other [4].  These two virtual envs are on the
> same machine.  I ran "git clean -fdx" to start over and now neither
> virtualenv can install it.
> Anyone have any idea what is going on?  It seems to be related to the
> fact that oslo.config is now uploaded as .whl files, whatever those
> are.  Why is it that my system cannot handle these?  I noticed that
> oslo.config is now available only as .whl in the versions
> but used to be available as .tar.gz files.
> Carl
> [1] http://paste.openstack.org/show/90651/
> [2] https://pypi.python.org/pypi/oslo.config
> [3] http://paste.openstack.org/show/90674/
> [4] http://paste.openstack.org/show/90675/
> _______________________________________________
> OpenStack-dev mailing list
> OpenStack-dev at lists.openstack.org
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

More information about the OpenStack-dev mailing list