[openstack-dev] Problems with all OpenStack APIs & uwsgi with Content-Lenght and connection reset by peer (ie: 104)

Thomas Goirand zigo at debian.org
Wed May 2 08:15:31 UTC 2018

Hi there!

It's been a month I was knocking my head on the wall trying to get uwsgi
working with all of OpenStack API uwsgi applications. Indeed, when
OpenStack component (like for example, nova-compute) were talking to
uwsgi, then they were receiving a 104 error (ie: connection reset by
peer) before getting an answer.

What was disturbing was that, doing the same request with curl worked
perfectly. Even more disturbing, it looked like I was having the issue
nearly always in virtualbox, but not always in real hardware, where it
sometimes worked.

Anyway, finally, I figured out that adding:

--rem-header Content-Lenght

fixed everything. I was able to spawn instances in virtualbox.

This however, looks like a workaround rather than a fix, and I wonder if
there's a real issue somewhere that needs to be fixed in a better way,
maybe in openstackclient or some other component...

Thoughts anyone?


Thomas Goirand (zigo)

More information about the OpenStack-dev mailing list