[openstack-dev] Problems with all OpenStack APIs & uwsgi with Content-Lenght and connection reset by peer (ie: 104)

Chris Dent cdent+os at anticdent.org
Wed May 2 08:25:56 UTC 2018

On Wed, 2 May 2018, Thomas Goirand wrote:

> What was disturbing was that, doing the same request with curl worked
> perfectly. Even more disturbing, it looked like I was having the issue
> nearly always in virtualbox, but not always in real hardware, where it
> sometimes worked.

What was making the request in the first place? It fails in X, but
works in curl. What is X?

> Anyway, finally, I figured out that adding:
> --rem-header Content-Lenght

You added this arg to what?

In both cases do you mean openstackclient?

> This however, looks like a workaround rather than a fix, and I wonder if
> there's a real issue somewhere that needs to be fixed in a better way,
> maybe in openstackclient or some other component...

Yeah, it sounds like something could be setting a bad value for the
content length header and uwsgi is timing out while trying to read
that much data (meaning, it is believing the content-length header)
but there isn't anything actually there.

Another option is that there are buffer size problems in the uwsgi
configuration but it's hard to speculate because it is not clear
what requests and tools you're actually talking about here.

Chris Dent                       ٩◔̯◔۶           https://anticdent.org/
freenode: cdent                                         tw: @anticdent

More information about the OpenStack-dev mailing list