[openstack-dev] [Sahara] [EDP] about get_job_status in oozie engine
juvenboy1987 at gmail.com
Wed Jun 24 02:36:59 UTC 2015
I am huichun
I agree with you, currently sahara edp engine and DB mixed with lots of
oozieness info, abstract incompletely.
i find this issue because i want add recurrence edp job in sahara, and with
oozie implementation, i find i need these oozie information not only the
so i will make a little change with current code with little impact, but in
the long term plan, I think we should make a disscussion about refactoring
current edp engine and oozie implementation
2015-06-23 21:17 GMT+08:00 Trevor McKay <tmckay at redhat.com>:
> Hi Lu,
> yes, you're right. Return is a dictionary and for the other EDP
> engines only "status" is returned (and we primarily care about
> "status"). For Oozie, there is more information.
> I'm fine with changing the name to "get_job_info()" throughout the
> job_manager and EDP.
> It actually raises the question for me about whether or not in the
> Oozie case we really even need the extra Oozie information in the Sahara
> database. I don't think we use it anywhere, not even sure the UI
> displays it (but it might) or how much comes through the REST responses.
> Maybe we should have get_job_status() which returns only "status", and
> an optional get_job_info() that returns more? But that may be a bigger
> On Tue, 2015-06-23 at 15:18 +0800, lu jander wrote:
> > Hi Trevor
> > in sahara oozie engine (sahara/service/edp/oozie/engine.py
> > sahara/service/edp/oozie/oozie.py)
> > function get_job_status actually returns not only the status of the
> > job, but it returns all the info about the job, so i think that we
> > should rename this function as get_job_info maybe more convenient for
> > us? cause I want add a function named get_job_info but i find that it
> > already exists here with a confused name.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the OpenStack-dev