[Openstack] Ocata Created Ports Strange Issue

Eugen Block eblock at nde.ag
Fri Feb 9 15:48:28 UTC 2018


my input on this is very limited, but I believe we had a similar issue  
in our Ocata cloud. My workaround was like yours, detach the assigned  
port, recreate it and attach it again. The only strange thing was,  
that when I wanted to delete the port, the CLI reported that the port  
didn't exist, it literally disappeared!
I didn't spend very much time to debug it because it has not happened  
since then. And if I remember correctly, it occured around our large  
migration, where we upgraded our Ceph backend to the latest version,  
upgraded the OS of all nodes and also the cloud from Mitaka to Ocata  
(via Newton), it could have been a side effect of that, at least that  
was my hope.

So as I said, this is not of big help, but I can confirm your  
observation, unfortunately without any pointers to the cause. If this  
happens again, I will definitely spend more time on debugging! ;-)


Zitat von Georgios Dimitrakakis <giorgis at acmac.uoc.gr>:

> Dear all,
> I have a small Ocata installation (1x controller + 2x compute nodes)  
> on which I have manually created 5 network ports and afterwards each  
> one of these ports is assigned to a specific instance (4Linux VMs  
> and 1Windows). All these instances are located on one physical  
> hypervisor (compute node) while the controller is also the  
> networking node.
> The other day we had to do system maintenance and all hosts (compute  
> and network/controller) were powered off but before that we  
> gracefully shutoff all running VMs.
> As soon as maintenance finished we powered on everything and I met  
> the following strange issue... Instances with an attached port were  
> trying for very long time to get an IP from the DHCP server but they  
> all manage to get one eventually with the exception of the Windows  
> VM on which I had to assign it statically. Restarting networking  
> services on controller/network and/or compute node didn't make any  
> difference. On the other hand all newly spawned instances didn't  
> have any problem no matter on which compute node they were spawned  
> and their only difference was that they were automatically getting  
> ports assigned. All the above happened on Friday and today (Monday)  
> people were complaining that the Linux VMs didn't have network  
> connectivity (Windows was working...), so I don't know the exact  
> time the issue occured. I have tried to access all VMs using the  
> "self-service" network by spawning a new instance unfortunately  
> without success. The instance was successfully spawned, it had  
> network connectivity but couldn't reach any of the afforementioned  
> VMs.
> What I did finally and solved the problem was to detach interfaces,  
> deleted ports, re-created new ports with same IP address etc. and  
> re-attached them to the VMs. As soon as I did that networking  
> connectivity was back to normal without even having to restart the  
> VMs.
> Unfortunately I couldn't find any helpful information regarding this  
> in the logs and I am wondering has anyone seen or experienced  
> something similar?
> Best regards,
> G.
> _______________________________________________
> Mailing list: http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack
> Post to     : openstack at lists.openstack.org
> Unsubscribe : http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack

Eugen Block                             voice   : +49-40-559 51 75
NDE Netzdesign und -entwicklung AG      fax     : +49-40-559 51 77
Postfach 61 03 15
D-22423 Hamburg                         e-mail  : eblock at nde.ag

         Vorsitzende des Aufsichtsrates: Angelika Mozdzen
           Sitz und Registergericht: Hamburg, HRB 90934
                   Vorstand: Jens-U. Mozdzen
                    USt-IdNr. DE 814 013 983

More information about the Openstack mailing list