[Openstack] Ocata Created Ports Strange Issue

Georgios Dimitrakakis giorgis at acmac.uoc.gr
Mon Feb 5 20:24:17 UTC 2018

 Dear all,

 I have a small Ocata installation (1x controller + 2x compute nodes) on 
 which I have manually created 5 network ports and afterwards each one of 
 these ports is assigned to a specific instance (4Linux VMs and 
 1Windows). All these instances are located on one physical hypervisor 
 (compute node) while the controller is also the networking node.

 The other day we had to do system maintenance and all hosts (compute 
 and network/controller) were powered off but before that we gracefully 
 shutoff all running VMs.

 As soon as maintenance finished we powered on everything and I met the 
 following strange issue... Instances with an attached port were trying 
 for very long time to get an IP from the DHCP server but they all manage 
 to get one eventually with the exception of the Windows VM on which I 
 had to assign it statically. Restarting networking services on 
 controller/network and/or compute node didn't make any difference. On 
 the other hand all newly spawned instances didn't have any problem no 
 matter on which compute node they were spawned and their only difference 
 was that they were automatically getting ports assigned. All the above 
 happened on Friday and today (Monday) people were complaining that the 
 Linux VMs didn't have network connectivity (Windows was working...), so 
 I don't know the exact time the issue occured. I have tried to access 
 all VMs using the "self-service" network by spawning a new instance 
 unfortunately without success. The instance was successfully spawned, it 
 had network connectivity but couldn't reach any of the afforementioned 

 What I did finally and solved the problem was to detach interfaces, 
 deleted ports, re-created new ports with same IP address etc. and 
 re-attached them to the VMs. As soon as I did that networking 
 connectivity was back to normal without even having to restart the VMs.

 Unfortunately I couldn't find any helpful information regarding this in 
 the logs and I am wondering has anyone seen or experienced something 

 Best regards,


More information about the Openstack mailing list