[Openstack] cinder volume status error: No weighed hosts found for volume with properties: {}

Ali Nazemian alinazemian at gmail.com
Fri Feb 6 09:33:48 UTC 2015

Dear all,
Recently I tried to install and configure Openstack juno on centos 7 x64.
For this purpose I did follow that installation guide for every part. There
were not any problem until installing block storage service. It seems that
every part of cinder installation was done according to the installation
manual. But when I tried to create a volume for the purpose of verifying
the installation process, I could not create cinder volume successfully. I
did install scheduler on controller node and cinder-volume on block1
node. "cinder
service-list" shows that both scheduler service and cinder-volume are up
and running.
"cinder list" command shows that the created volume is in error status.
Worth to mentioned that "cinder type-list" shows nothing. (empty list)
Here is the output of volume.log on block1 node:

WARNING cinder.volume.manager [-] Unable to update volume replication
status, LVMISCSIDriver -2.0.0  driver is uninitialized.
INFO cinder.volume.manager [-] Updating volume replication status.

Here is the output of scheduler.log on controller node:

WARNING cinder.scheduler.filter_scheduler
[req-59debb2a-96bb-4c17-ac54-1d0018e69f05 f76c6babe6f74d8ebfb6b396ecb959f6
699fcdbd76d64bd184fc948ac1e9b32c - - -] No weighed hosts found for volume
with properties: {}

ERROR cinder.scheduler.flows.create_volume
[req-59debb2a-96bb-4c17-ac54-1d0018e69f05 f76c6babe6f74d8ebfb6b396ecb959f6
699fcdbd76d64bd184fc948ac1e9b32c - - -] Failed to run task
No valid host was found. No weighed hosts available

I really appreciate if somebody can help me in solving this issue.
Best regards.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20150206/120fdd99/attachment.html>

More information about the Openstack mailing list