[Openstack] [Nova Network] Hosts lost connectivity but not instances

Naman Muley naman.g.muley at gmail.com
Wed May 7 13:37:04 UTC 2014


I have a multi-node install of openstack havana. Until yesterday I had all
the nodes and instances with proper connectivity, using FlatDHCPManager.

Today, when I tried to check connectivity, all compute hosts are unable to
send a ping outside the machine. Curiously, the instances are still able to
use the br100 and ping outside their respective hosts. Also, I am able to
ping the host from outside. (i.e. ping works in reverse direction).

Ping from host(wind - eth0: to outside(
xxxx at wind:~$ ping
PING ( 56(84) bytes of data.
>From icmp_seq=1 Destination Host Unreachable
>From icmp_seq=2 Destination Host Unreachable
>From icmp_seq=3 Destination Host Unreachable

It is curious that ping says "From". I am unable to understand
this. It is as if br100 has taken over eth0 as the default interface.

route -n on host(wind)
ncsu at wind:~$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use
Iface         UG    100    0        0 eth1   U     0      0        0
lxcbr0   U     0      0        0
br100   U     0      0        0 eth0   U     0      0        0 eth1

relevant interface information for wind
eth0 -
br100 -
eth1 - (mgmt interface)

I've tried restarting nova services and rebooting to no avail. I am unable
to troubleshoot it. Any ideas?


ps: I did notice that I was tinkering with NATs and iptables before this
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20140507/9db4f058/attachment.html>

More information about the Openstack mailing list