[Openstack] Openstack in centos and Xen sever- Single node setup

Bob Ball bob.ball at citrix.com
Wed Aug 28 10:18:16 UTC 2013

Just for completeness, a little explanation.

The XenServer installation for devstack (assuming you used https://raw.github.com/citrix-openstack/qa/master/install-devstack-xen.sh) does use a combination of Nova master and fixes needed to run master on XenServer (all of which changes - if there are any - are pending review).

This is through the settings:

If you want to install Nova from master then either edit the script to remove those lines, or run the script without any parameters and it will generate a localrc.template which can be edited to remove the lines.

We've recently added the unit tests to the tests that we run in our CI (rather than relying on the unit tests run through Jenkins) - so hopefully the issue you encountered won't occur again.

On the other hand, there have been periods where nova master does not work correctly with XenServer without these fix-ups, so either approach has a risk since it's not the stable release.


From: Christopher Lefelhocz [mailto:christopher.lefelhoc at RACKSPACE.COM]
Sent: 28 August 2013 04:54
To: Bob Ball; SriHarish Ramesh; openstack at lists.openstack.org
Subject: Re: [Openstack] Openstack in centos and Xen sever- Single node setup

To Bob's point, I was able to follow these instructions in the past week and successfully get XenServer 6.2 up and running.  The only caution I would give is that buried in there is a link to "XenServer and DevStack".  While it does build a working running devstack, the branch of nova is not the master.  When I ran the unit testing on the branch many unit tests failed.  It's a relatively easy fix to move to the master, which to this point has not had any issues for me (though my testing has been limited).


From: Bob Ball <bob.ball at citrix.com<mailto:bob.ball at citrix.com>>
Date: Tuesday, August 27, 2013 1:33 AM
To: SriHarish Ramesh <eie.harish at gmail.com<mailto:eie.harish at gmail.com>>, "openstack at lists.openstack.org<mailto:openstack at lists.openstack.org>" <openstack at lists.openstack.org<mailto:openstack at lists.openstack.org>>
Subject: Re: [Openstack] Openstack in centos and Xen sever- Single node setup

The guide for setting up OpenStack with XenServer is at http://docs.openstack.org/trunk/openstack-compute/admin/content/introduction-to-xen.html.

I would personally recommend using XenServer 6.2 as that is fully open source and includes features such as the live storage migration in the free version.  XenServer 5.6 is now very dated.

The "No host is available" is simply a message that says the controller node has not been set up properly - although it's not clear from your nova.conf snippet why that is.  You'll need to check the output produced by Nova to see what the error in connecting was.  It might be to do with network setup, or the username/password details.

Unfortunately I don't have experience of RDO but I would hope that the nova output is redirected to a log file, possibly in /var/log.



From: SriHarish Ramesh [mailto:eie.harish at gmail.com]
Sent: 26 August 2013 13:29
To: openstack at lists.openstack.org<mailto:openstack at lists.openstack.org>
Subject: [Openstack] Openstack in centos and Xen sever- Single node setup


I have installed XEN 5.6 in a physical machine and Openstack(Grizzly)in CentOS VM separately following RDO guide.
I have changed the answer file and updated the xen machine details. xen machine and centos vm are in the same network.




I tried restarting the centos machine and via dashboard when trying to create a VM, "No host is available" message is thrown.
I managed to deploy openstack in centos, but not  able to add host to the openstack.
Is there a step by step guide to configure the host to openstack?

Thanks and Regards
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20130828/4277dfdc/attachment.html>

More information about the Openstack mailing list