[Openstack] Something horribly wrong with NFS

Marco CONSONNI mcocmo62 at gmail.com
Tue Dec 11 17:11:12 UTC 2012

Hi all,

some more information for further investigation on the "horrible behavior".

The phenomenon seems to be related to the concurrent access of the shared
file system.

In fact, in my NFS deployment I noticed that problems started when a new VM
was booted on a node different from the one where the already running VMs
were booted (see the scheduling policy I briefly mentioned in my previous

Let me describe what I experimented:

1) I launched Vm1 and it started to Node1
2) I launched Vm2 and it started to Node1


8) I launched Vm8 and it started to Node1

<< at this point Node1 was full >>

9) I launched Vm9 and it started to Node2

<< at this point the cloud was stuck (I couldn't start new VMs and the
already running VMs didn't perform properly) >>

The only action I was able to do was to delete VMs.

Hope it helps,

On Tue, Dec 11, 2012 at 5:54 PM, Marco CONSONNI <mcocmo62 at gmail.com> wrote:

> Hello Andrew,
> using NFS for live migration I found strange behaviors too.
> To be more specific, I noted that at a certain point I couldn't boot any
> new VM.
> Live migration in itself was fine provided that I didn't reach a number of
> concurrent VMs; the problem was that after a number of VMs (in my case 8)
> the cloud stopped working.  I could do much but stopping VMs.
> In my case I set up the scheduling in a way that all the VMs were
> 'dispatched' to a compute node till such a node was 'full'.
> At the end I decided not to use it and use gluster, instead.
> I followed the instructions reported here
> http://gluster.org/community/documentation//index.php/OSConnect with some
> modifications for having a single node running as a gluster server and all
> the compute nodes running as gluster clients.
> Something similar to what you deploy when you use NFS.
> Note that my deployment is not going to be a production installation,
> therefore a single gluster file server is OK.
> Also note that I started my installation using Ubuntu 12.04 but the
> migration didn't work properly for problems in the hypervisor,
> With 12.10 everything worked properly.
> Hope it helps,
> Marco.
> On Tue, Dec 11, 2012 at 5:33 PM, Andrew Holway <a.holway at syseleven.de>wrote:
>> Hello,
>> I tried this today:
>> http://docs.openstack.org/trunk/openstack-compute/admin/content/configuring-migrations.html
>> Everything seemed to break really horribly.
>> Is this documentation up to date? I am going to completely reinstall
>> tomorrow.
>> I am using Centos 6.3
>> Thanks,
>> Andrew
>> _______________________________________________
>> Mailing list: https://launchpad.net/~openstack
>> Post to     : openstack at lists.launchpad.net
>> Unsubscribe : https://launchpad.net/~openstack
>> More help   : https://help.launchpad.net/ListHelp
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20121211/916445c9/attachment.html>

More information about the Openstack mailing list