[Openstack] Multinode installation (with devstack on the master)

Frost Dragon frostdragon777 at gmail.com
Sat Dec 31 07:18:02 UTC 2011

Hi Anthony,
    Thank you very much. That worked like a charm. I can now launch
and access instances running on different nodes. Instances without
disk storage (m1.tiny) work great. But when I try to use flavors with
disk storage, the dashboard displays an 'Error' state after the
'Build' state. Since the console log is empty, I have no idea why it
is going into this state. I'm running nova-volume on both nodes and
I'm not using swift on either of them.

Thanks and regards,

On 12/31/11, Anthony Young <sleepsonthefloor at gmail.com> wrote:
> Hey Sagar,
> I'll take a quick guess here that maybe your servers have host names that
> don't resolve.  So for example, if host1 is 'server1' and host2 is
> 'server2' the vnc proxy may try connect using those hostnames (connecting
> to the latter host would probably fail).  A quick fix could be to add an
> entry in your master /etc/hosts for the second server's hostname.
> Anthony
> On Fri, Dec 30, 2011 at 2:02 PM, Frost Dragon
> <frostdragon777 at gmail.com>wrote:
>> Hi,
>>     Thanks for the replies. I tried a clean installation with eth1 as my
>> flat interface and it worked perfectly well. I can now ping and SSH to my
>> VMs on either node from the other. They're also getting their metadata
>> correctly. Only problem is that I can't access VMs on the second node via
>> the console on the dashboard running on the first node. I'm getting a
>> 'Failed to connect to server' message. However, I can view the VMs running
>> on the master node through the vnc console. Is this related to
>> nova-vncproxy? The services I'm running on the second node are
>> n-vol,n-cpu,n-net and n-api.
>> Thanks and regards,
>> Sagar

More information about the Openstack mailing list