[Openstack-operators] Problem setting up Rally with Keystone V3

Boris Pavlovic boris at pavlovic.me
Tue Nov 28 19:32:48 UTC 2017


Yep you are right we don't import PROJECT_ID variable according to the code

It's should be easy to fix patch, you are welcome to report bug and you can
even fix it (seems like 1 line change).

Best regards,
Boris Pavlovic

On Tue, Nov 28, 2017 at 6:25 AM, Aleksander Okonski <
aleksander.oko at gmail.com> wrote:

> Hello,
> I am currently trying to set up Rally so that it will connect with an
> OpenStack deployment. I am able to set up Rally with no problem (via the
> install script) and I source the needed openrc file. Once that is set up I
> issue the command:
> rally deployment create --fromenv --name=test
> Rally sets up the deployment with no problems.
> However once I try to run
> rally deployment check
> I get back the following error.
> AuthenticationFailed: Failed to authenticate to https://--address--:5000/v3
> for user '--user--' in project '--project--': Unauthorized: The request you
> have made requires authentication. (HTTP 401) (Request-ID:
> req-563529b8-36f1-4c7c-b376-b420bf6af8c5)
> I believe I have found the cause of the problem to be that Rally does not
> pull in the PROJECT_ID environment variable when the deployment is created.
> When I run the OpenStack CLI with the same source file I can attach to the
> instance and get the proper behavior. But taking out the PROJECT_ID will
> cause the OpenStack CLI to produce the same error.
> When I have tested Rally before and it was working with Keystone V2
> however moving to the new deployment we have Keystone V3 running.
> If any one has encountered a similar problem or could point me in the
> right direction I would really appreciate it.
> OpenStack CLI version -- openstack 3.12.0
> Rally version -- 0.10.1~dev17
> Keystone -- V3
> Best,
> Aleksander
> _______________________________________________
> OpenStack-operators mailing list
> OpenStack-operators at lists.openstack.org
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-operators
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20171128/af9e646e/attachment.html>

More information about the OpenStack-operators mailing list