[Openstack-operators] Error: Actor Crashed

Riccardo Diago riccardo.diago at gmail.com
Mon Nov 9 14:05:38 UTC 2015

Hi all,

I don't know if this problem is ok for this list.  If not, please
address me into the right one.
Anyway, here the problem:

I was trying running stable/kilo branch infrastructure with the
following setting of chef dk:

  * Chef Development Kit Version: 0.9.0
  * chef-client version: 12.5.1
  * berks version: 4.0.1
  * kitchen version: 1.4.2

But when I run the command:

  * chef exec rake berks_vendor

I got the following error:

[2015-11-07T11:14:21.289451 #10681] ERROR -- : Actor crashed!
Errno::EHOSTUNREACH: No route to host - connect(2) for "s3.amazonaws.com
<http://s3.amazonaws.com>" port 443

I have also checked the knife.rb which looks like this:

current_dir = File.dirname(__FILE__)
log_level :info
log_location STDOUT
node_name 'nodienode'
client_key "#{current_dir}/nodienode.pem"
validation_client_name 'chef-validator'
validation_key "#{current_dir}/validator.pem"
chef_server_url 'https://api.opscode.com/organizations/my_awesome_org'
cache_type 'BasicFile'
cache_options(path: "#{ENV['HOME']}/.chef/checksums")
cookbook_path ["#{current_dir}/../cookbooks"]
knife[:secret_file] = "#{current_dir}/encrypted_data_bag_secret"

I tried google it, but I don't find a solution.
I checked also my firewall and my routing table, all of them are ok.

Can someone help me out, please ?

Thanks for any suggestion.

Riccardo ( aka diagor)

More information about the OpenStack-operators mailing list