[Openstack-operators] [nova docker]need help for nova-docker

hittang hitgwt at 163.com
Tue Nov 3 00:51:04 UTC 2015

Hi, Dims.
  I have saw that note about "long lived process" in dova-docker READEME file. I have tried redis image and ubuntu-sshd image,and the two images worked well. And then, I write a simple python code which like that "while True: print 'hello world' ", and put that code input redis image ,this also worked. but when I tried use 'ping localhost' or 'ping IP ADDRESS', it errors again. I think maybe the network was not ready,so the app raise exception and the container exits. So, I change the code like that :1 use sleep-wait for check if the network is ready, 2 check if eth0's ip address is ready 3 run ping application or other app which only sending packets. This also errors and exits.

At 2015-11-02 19:25:27, "Davanum Srinivas" <davanum at gmail.com> wrote:


please see the note about "long lived process" in nova-docker README file. This happens when the process started in the container exits before network is setup. you should also check docker logs to see if there is any error.


On Mon, Nov 2, 2015 at 1:30 AM, hittang <hitgwt at 163.com> wrote:

Hi, everyone.
 I install nova docker driver by https://wiki.openstack.org/wiki/Docker . but when I create a docker instance, it doesn't work.the errors like that "Cannot setup network: Cannot find any PID under container" Can anybody help me ?


OpenStack-operators mailing list
OpenStack-operators at lists.openstack.org


Davanum Srinivas :: https://twitter.com/dims
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20151103/1efc79fb/attachment.html>

More information about the OpenStack-operators mailing list