[Openstack-operators] Way to check compute <-> rabbitmq connectivity

Joe Topjian joe at topjian.net
Thu Jan 15 16:29:26 UTC 2015

Hi Kris,

 Our experience is pretty much the same on anything that is using rabbitmq
> - not just nova-compute.

Just to clarify: have you experienced this outside of OpenStack (or Oslo)?

We've seen similar issues with rabbitmq and OpenStack. We used to run
rabbit through haproxy and tried a myriad of options like setting no
timeouts, very very long timeouts, etc, but would always eventually see
similar issues as described.

Last month, we reconfigured all OpenStack components to use the
`rabbit_hosts` option with all nodes in our cluster listed. So far this has
worked well, though I probably just jinxed myself. :)

We still have other services (like Sensu) using the same rabbitmq cluster
and accessing it through haproxy. We've never had any issues there.

What's also strange is that I have another OpenStack deployment (from
Folsom to Icehouse) with just a single rabbitmq server installed directly
on the cloud controller (meaning: no nova-compute). I never have any rabbit
issues in that cloud.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20150115/f4982d0f/attachment.html>

More information about the OpenStack-operators mailing list