Devstack Installation Fails with Internal Server Error (HTTP 500)

melanie witt melwittt at
Thu Jun 16 22:11:54 UTC 2022

On Tue Jun 14 2022 08:15:57 GMT-0700 (Pacific Daylight Time), Sean 
Mooney <smooney at> wrote:
> On Tue, 2022-06-14 at 06:37 -0700, Dan Smith wrote:
>>> i hit the same issue the other day if you recall me asking about it.
>>> didnt check my devstack logs to see if it installed or not but i can
>>> see if i can repoduce it tomorrow.
>> I checked with the OP and they have it installed properly,
>> system-wide. I was assuming your issue might have been venv (or
>> ordering) related, but theirs was not. There are some other weird things
>> going on with their setup, so I'm not so sure.
> nope, was not useing a vnev or anything special, it just devstack installed normaly more or less
> but driven by the ansible roles. the run devstack rull litrally just opens a shell and invokes
> so i dont think there was anything specific ot how i was invoking it.

I saw this today while trying to re-install ( an existing 
devstack ( and I did a fresh devstack after this 
and it worked without any problems. So maybe the behavior is intermittent?

The error in the g-api log [1] during service startup was:

Jun 16 19:25:26 node1 devstack at g-api.service[421305]: ERROR 
glance.common.wsgi sqlalchemy.exc.NoSuchModuleError: Can't load plugin: 

The format of the above plugin message is <group>:<name> [2] which would 
mean the group is 'sqlalchemy.plugins' and the name is 
'dbcounterplugin=dbcounterplugin=dbcounter'. I thought the latter looked 
strange. I thought the name would just be 'dbcounter'.

The dbcounter package was installed:

$ pip show dbcounter
Name: dbcounter
Version: 0.1
Summary: A teeny tiny dbcounter plugin for use with devstack
Author: Dan Smith
Author-email: dms at
License: Apache
Location: /usr/local/lib/python3.8/dist-packages

When I tried something like this, it imported fine:

$ python3
Python 3.8.10 (default, Mar 15 2022, 12:22:08)
[GCC 9.4.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
 >>> import dbcounter
 >>> dbcounter
<module 'dbcounter' from 

Is it possible dbcounter was not installed at the time glance was 
starting up? I didn't think so given the timestamp on the package dir:

$ ls -l /usr/local/lib/python3.8/dist-packages/|grep dbcounter
drwxr-sr-x  2 root staff    4096 Jun 16 19:14 dbcounter-0.1.dist-info
-rw-r--r--  1 root staff    4580 Jun 16 19:14

and the error above happened at Jun 16 19:25:26.

I couldn't figure out anything so finally I tried restarting the g-api 
service and it started without any error. Subsequent restart also had no 



More information about the openstack-discuss mailing list