Problem while launching an instance directly from an image "Volume did not finish being created even after we waited 203 seconds or 61 attempts"

Rajat Dhasmana rdhasman at
Mon Jul 4 04:46:56 UTC 2022


On Fri, Jul 1, 2022 at 3:04 PM A Monster <amonster369 at> wrote:

> I've deployed openstack using kolla, when I try to launch an instance
> directly from any image, after some time waiting for Block Device Mapping I
> get the following error :
I'm confused here, when you say directly from image, do you mean ephemeral
volumes (nova) or persistent volumes (cinder)? I will assume cinder volumes
since we've BDM here and nova is triggering cinder to create bootable

>  Build of instance 4cf01ba2-05b3-44e9-a685-8875d8c96b4e aborted: Volume
>> 01739e82-9e66-41f7-be74-dfbbdcd6746e did not finish being created even
>> after we waited 203 seconds or 61 attempts. And its status is creating.
> I've tried increasing  *block_device_allocate_retries=400 *and *block_device_allocate_retries_interval=3
> *, however I keep getting the same error.
> But when I create a volume from an image, then launch an instance from
> that same volume, it works just fine.
> Any suggestions for this issue?

Which OpenStack release you're working on?
I think the operation is failing asynchronously on the cinder side
(probably in c-vol) and nova times out waiting for a response. I suggest
you check cinder logs (c-api, c-sch, c-vol) for a more specific error

Thanks and regards
Rajat Dhasmana
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the openstack-discuss mailing list