[manila][ussuri] Manila return 404 resource not found after simple install

CHANU ROMAIN romain.chanu at univ-lyon1.fr
Mon Apr 11 12:29:58 UTC 2022


I tried to install manila on Ubuntu servers and I'm stuck during the
first steps. I followed this documentation:


When I tried to verify the operation I always get the same message:

# manila service-list
ERROR: Not Found (HTTP 404)

In manila-api.log
2022-04-11 12:12:56.533 125 INFO eventlet.wsgi.server [req-c03111de-
59bc7ad25c364c809a97c1a55caec161 - - -] IP_CLIENT,IP_LB "GET
/v2/services HTTP/1.1" status: 404  len: 228 time: 0.1233838

If I use -d

#manila -d service-list
DEBUG (connectionpool:208) Starting new HTTP connection (1): FQDN
DEBUG (connectionpool:396) http://FQDN:8786 "GET /v2/services HTTP/1.1"
404 112
RESP: [404] {'Content-Length': '112', 'Content-Type':
'application/json', 'Date': 'Mon, 11 Apr 2022 12:14:51 GMT'}
RESP BODY: {"message": "The resource could not be found.<br /><br
/>\n\n\n", "code": "404 Not Found", "title": "Not Found"}

Services are running, database is populated, rabbitmq has some
exchanges... I currently run out of ideas... Did someone already face
this issue?

Best regards,
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4513 bytes
Desc: not available
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20220411/f9dc06c1/attachment.bin>

More information about the openstack-discuss mailing list