Unable to attach a Volume to Openstack WIndows instance

KK CHN kkchn.in at gmail.com
Fri Sep 3 06:59:10 UTC 2021


I am trying to import a multi disk  Windows VM ( 100GB bootable disk and
600 GB data volume disk) exported from HyperV  to Openstack(Ussuri,
Qemu-KVM, Glance image store, Cinder volume with Ceph backend).

I am able to import the  First bootable disk(vhdx converted to qcow2  )
with Windows VM  in the OpenStack and its up and running able to login.

ONE BASIC queston  I not perfomed the  *"Virt IO Injection steps"* as I am
not sure whether for existing Windows VMs exported from HyperV  need this
Injection or not .

Some one can clarify or defend this statement  * " That   Any   Windows VM
with Volume disks  attached to it  running on Other  HyperVisor( say HyperV
in my case, oVirt) exported to  openstack which uses   qemu-kvm   needed
the   VirtIO Injection must done before importing to OpenStack with KVM
for these Windows VMs for up and running    and for attaching   volume
disks which also exported from other hypervisors . "        OR only
performance improvement only VirtIO injection do, so that I can avoid
VirtIO injection for  importing WIndowsVMs with multi disk to OpenStack.*

used this step to import the converted bootable disk to  my openstack.

# openstack    image   create     “Your_Windows_VM_NAME_Blaah”    --file
Windows_VM_disk1.qcow2    --disk-format  qcow2   --container-format
bare       --public    --property   hw_firmware_type=uefi
                     --property   os_secure_boot=required
--property        hw_disk_bus=ide

I am trying to import the second disk

# openstack  image create   “Your_Windows_VM_NAME_Blah”  --file
   Windows_VM_disk2.qcow2   --disk-format  qcow2  --public

and tried to create Volume through horizon dashboard with this image and
600 GB space. But volume creation itself showing status  creating  for more
than 1 hour for now .  Is this usual behaviour or  some this wrong ?

Note:  so this volume creation from image is taking long time.

As trial and error method I tried to create a small plain volume and attach
this to the running WIndows VM(Windows2012 RC). But failed.

  I tried to create a plain 20 GB volume from the Horizon GUI  and its
created with in 30 seconds..

And tried to attach this volume to the Windows VM disk1 which is running
and not got attached.  ( I  shutdown the Windows VM and tried to attach)
same result. not attached.

A plain volume also unable to got attached to the Windows VM ? why ?

But  the large 600GB goes for long hours.  ( yesterday also tried and it was
in creating state for 5 to 10 hours and I was waiting with no use, then I used
the cinder command to change the volume status to "available" and then
removed the volume which had not yet changed the state from "creating"  to
``available" .

Why do these volume creations  with large disk space go for hours ? Are
there any short steps to make it fast ?

Any hints most
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-discuss/attachments/20210903/370f4938/attachment.html>

More information about the openstack-discuss mailing list