python_requires >= 3.8 during Yoga

Dmitry Tantsur dtantsur at
Fri Nov 26 10:47:42 UTC 2021

Hi all,

Note that this decision will force us to stop supporting Bifrost [1] on
CentOS/RHEL completely, unless we find a workaround. While Python 3.8 and
3.9 can be installed, they lack critical modules like python3-dnf or
python3-firewalld, which cannot be pip-installed (sigh).

A similar problem in Metal3: we use python3-mod_wsgi, but I guess we can
switch to something else in this case.


[1] An upstream installation service for Ironic based on Ansible

On Thu, Nov 25, 2021 at 7:19 PM Stephen Finucane <stephenfin at>

> gmann has been helpfully proposing patches to change the versions of Python
> we're testing against in Yoga. I've suggested that we might want to bump
> 'python_requires' in 'setup.cfg' to indicate that we no longer support any
> version of Python before 3.8 [1]. As gmann has noted, doing so would mean
> nova
> would no longer be installable on Python 3.6 or 3.7 and there has been a
> small
> bit of back and forth on the pros and cons of this. I'm wondering what
> other
> people's thoughts on this are. Is this something we should be doing?
> Should we
> do it for libraries too or just services? Do we ever want to do this?
> Thoughts,
> please!
> Stephen
> [1]

Red Hat GmbH, , Registered seat: Grasbrunn,
Commercial register: Amtsgericht Muenchen, HRB 153243,
Managing Directors: Charles Cachera, Brian Klemm, Laurie Krebs, Michael
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the openstack-discuss mailing list