[kolla-ansible][wallaby][magnum] calico works, flannel does not work

Jake Yip jake.yip at ardc.edu.au
Mon Nov 22 09:01:28 UTC 2021


It could be due to https://github.com/flannel-io/flannel/issues/1155. 
One way to find out is to restart all the flannel pods after the cluster 
has been created,

kubectl -n kube-system delete pod -l app=flannel

Hope this helps.


On 22/11/21 12:27 am, wodel youchi wrote:
> Hi,
> I don't have any experience in kubernetes yet, my goal in the present is 
> to test that the auto-sacele of a kubernetes cluster is working properly 
> using magnum.
> I followed some tutorials to get the test done. I tried to configure the 
> test but I had problems with magnum-metrics-server not being able to 
> provide metrics, after digging and reading a lot of things on the web, I 
> found out that kubernetes master couldn't connect to the metrics server 
> (curl -k https://ip_metrics_server <https://ip_metrics_server> didn't work)
> So I created another template but this time using calico as a network 
> provider, and this time it worked.
> How can I find why flannel does not work? where should I look?
> Regards.

More information about the openstack-discuss mailing list