Nova not updating to new size of an extended in-use / attached cinder volume (Ceph RBD) to guest

Lee Yarwood lyarwood at
Mon Feb 15 11:18:34 UTC 2021

On 15-02-21 00:52:52, Christian Rohmann wrote:
> Hello Openstack-Discuss,
> after some digging I found out that cinder learned to resize attached
> (in-use) volumes quite a while ago with the introduction
> of the initial "extend 'in-use' volume" feature:
> The support was then extended to also cover Ceph RBD backed volumes with:
> Since this is only about the cinder part, I was wondering if nova would ever
> find out and would actively rescan the device / volume and quintessentially
> present an increased new size to the guest. Apparently this is where a
> certain volume-extended event comes into play:
> that is to be emitted
> by cinder when a volume had been extened.
> I then went head and tried this with the openstack cli (as Horizon does not
> seem to support / offer to resize in-use volumes.
> I run Openstack Train with Ceph RBD as storage. First I ran into an issue
> with the openstack cli
> (
> <>) but using
>   cinder extend $volumeid $newsize
> I was able to resize in-use volumes just fine.
> The only thing missing was the propagation to the guest. I played around
> with SCSI rescans, but that did not work, reboots also failed to do anyting
> in this regards. Stopping and starting the VM did work, but why having the
> capability to online-resize an attached volume when not being able to resize
> the guest volume as well?
> Apparently there seems to be an old and somewhat similar observation / bug
> with
That's an unrelated bug about ephemeral disk resize. 
> So I was simply wondering if this is expected to be working?
> Are there any special settings / options I need to set to enable this
> feature?

Yes this should work without any additonal changes, can you write up
a nova bug with the following output in addition to the bug template:

- Your versions of libvirt and QEMU.

- Output of the following command *after* requesting a resize:

$ virsh domblkinfo $instance_uuid $target_dev

- Output of the following commands once confirmed the resize didn't
  happen within the domain:

$ virsh blockresize $instance_uuid $rbd_path $new_size
$ virsh domblkinfo $instance_uuid $target_dev

>From what you've said above this smells like a libvirt/QEMU bug but I
don't have a rbd env to hand to confirm things at the moment.


Lee Yarwood                 A5D1 9385 88CB 7E5F BE64  6618 BCA6 6E33 F672 2D76
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: not available
URL: <>

More information about the openstack-discuss mailing list