[undercloud][train]Fatal error during train undercloud deployment

Alex Schultz aschultz at redhat.com
Mon Nov 2 14:16:54 UTC 2020

On Mon, Nov 2, 2020 at 5:11 AM dangerzone ar <dangerzonen at gmail.com> wrote:
> Hi all, I keep getting the same fatal error below during undercloud deployment. My environment is VMware VM Centos7 undercloud (openstack train) and refers to the official openstack guideline.
> TASK [tripleo_container_manage : Print failing containers] *********************
> Monday 02 November 2020  19:55:07 +0800 (0:00:00.182)       0:17:50.677 *******
> fatal: [undercloud]: FAILED! => changed=false
>   msg: 'Container(s) with bad ExitCode: [u''container-puppet-ironic'', u''container-puppet-zaqar''], check logs in /var/log/containers/stdouts/'
> I even tried with clean different VM and all give me same error. Appreciate some help please. Thank you.

Check containers, they are likely centos8 based containers which fail
when trying to deploy on centos7. At this point it's highly
recommended to use centos8 for train as it's readily available from
RDO now.

More information about the openstack-discuss mailing list