About Devstack

Sean Mooney smooney at redhat.com
Mon Aug 24 11:41:51 UTC 2020

On Mon, 2020-08-24 at 16:32 +0900, Bernd Bausch wrote:
> Devstack is not meant to be restarted. However, setting the IP address 
> on br-ex and bringing it up is normally sufficient to re-establish 
> networking. After that, you probably still need to recreate the loop 
> devices for Cinder and Swift.
devstack used to support restart with a seperate script. That was remvoed
but when we latter swapped to systemd it almost fixed restart there
are a cloule of things that are not done porperly to allow restart to work
but really we should proably just fix those. some run directores are missng after
the reboot that prevent some wsgi servicces restarting if you correct that i think that
is basically all tha tis needed.
> What I don't understand: The external network that Devstack sets up by 
> default, named "public", is fake. It's not external, and it's not 
> connected to the outside world at all, thus the IP address range of 
> How your instances were able to access the internet 
> without any manual tweaking is a mystery to me. If you did some manual 
> tweaking, I guess it was lost when you rebooted.
> Perhaps you had a non-persistent routing table entry that connected 
> to the outside world?

this might help. the networking is not exactly fake but if you dont configure your br-ex to have
a port attached and configure your router as the gateway for the network you wont have connectivity

you can alternitivly nat the traffic form openstack.

there are some devstack docs on how to configure networing
but basically devstack will not majically make your openstack network routeable on your physical network you have to
do some manual operatoin on your router to make that happen.
> Bernd.
> On 8/22/2020 10:24 AM, 閺夊骸绻旀潻锟 wrote:
> > I'm sorry to disturb you.
> > Recently, I tried to install openstack through devstack. When I input 
> > "./stack.sh". I can install openstack successfully.
> > Then I tried to create a cloud instance and use the public network 
> > <> which is created during 
> > installation( this subnet is created by default, I didn't configure 
> > network informartion in local.conf before installation). And the 
> > instance can access to the Internet smoothly.
> > But the instance will not access the Internet when I reboot my server鑱 
> > (physical machine). After rebooting, I input "sudo ifconfig br-ex 
> > <> up", the instance can access my 
> > server IP, but it can't PING the gateway addresses of my server. Of 
> > course, the instance also can't access the Internet. But my server can 
> > PING it's gateway and access to the Internet. Finally, the cloud 
> > instance can only communicate with my server.
> > I tried many methods to restore the network environment of my 
> > openstack. But I can't find the reason. So I need your help. I install 
> > the version of devstack is stable/train. Thank you very much!

More information about the openstack-discuss mailing list