Firmware Update (cleaning step) issues

Martin Sysadmin chilliblast75 at
Tue Mar 5 09:07:40 UTC 2019

Hi all

I wondered if anybody had managed to update ILO firmware via openstack
cleaning step?


openstack triple-o / RDO containerised deployment (ironic_conductor etc is
a Docker container on the under cloud)

I have constructed a JSON file with the contents as follows:



    "interface": "management",

    "step": "update_firmware",

    "args": {

      "firmware_update_mode": "ilo",



          "url": "https://.../..../CP0xyz.scexe",

          "checksum": "<checksum_value>",

          "component": "ilo"






which I then initiate a clean step test using following:

openstack baremetal node clean --clean-steps fw_update_test.json

and this fails with the error "Clean step update_firmware *failed* on node
<<node_uid>> with the error: Unable to update firmware" when looking in

I have tested this myself by importing proliantutils into my own test
Python script, it doesn't matter what URL I provide it fails with the error

Has anyone managed to get this step working at all? I have also tried with
unpacked image (.bin file) and the same error.

Would appreciate any tips

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the openstack-discuss mailing list