[openstack-dev] [tripleo] Install Kubernetes in the overcloud using TripleO

Jiří Stránský jistr at redhat.com
Wed Sep 20 09:49:05 UTC 2017

On 20.9.2017 10:15, Bogdan Dobrelya wrote:
> On 08.06.2017 18:36, Flavio Percoco wrote:
>> Hey y'all,
>> Just wanted to give an updated on the work around tripleo+kubernetes.
>> This is
>> still far in the future but as we move tripleo to containers using
>> docker-cmd,
>> we're also working on the final goal, which is to have it run these
>> containers
>> on kubernetes.
>> One of the first steps is to have TripleO install Kubernetes in the
>> overcloud
>> nodes and I've moved forward with this work:
>> https://review.openstack.org/#/c/471759/
>> The patch depends on the `ceph-ansible` work and it uses the
>> mistral-ansible
>> action to deploy kubernetes by leveraging kargo. As it is, the patch
>> doesn't
>> quite work as it requires some files to be in some places (ssh keys) and a
>> couple of other things. None of these "things" are blockers as in they
>> can be
>> solved by just sending some patches here and there.
>> I thought I'd send this out as an update and to request some early
>> feedback on
>> the direction of this patch. The patch, of course, works in my local
>> environment
>> ;)
> Note that Kubespray (former Kargo) now supports the kubeadm tool
> natively [0]. This speeds up a cluster bootstrapping from an average
> 25-30 min to a 9 or so. I believe this makes Kubespray a viable option
> for upstream development of OpenStack overclouds managed by K8s.
> Especially, bearing in mind the #deployment-time effort and all the hard
> work work done by tripleo and infra teams in order to shorten the CI
> jobs time.

I tried deploying with kubeadm_enable yesterday and no luck yet on 
CentOS, but i do want to get back to this as the speed up sounds 
promising :)

AIO kubernetes deployment the non-kubeadm way seemed to work fine 
(Flavio's patch above with a workaround for [2] and a small Kubespray 
fix [3]).


> By the way, here is a package review [1] for adding a kubespray-ansible
> library, just ansible roles and playbooks, to RDO. I'd appreciate some
> help with moving this forward, like choosing another place to host the
> package, it got stuck a little bit.
> [0] https://github.com/kubernetes-incubator/kubespray/issues/553
> [1] https://bugzilla.redhat.com/show_bug.cgi?id=1482524
[2] https://bugs.launchpad.net/mistral/+bug/1718384
[3] https://github.com/kubernetes-incubator/kubespray/pull/1677

More information about the OpenStack-dev mailing list