[openstack-dev] [infra][qa] Zuulv3 jobs fail due to an authentication issue

Martin Kopec mkopec at redhat.com
Mon Nov 27 15:56:45 UTC 2017


I'm having authentication issues during running my zuulv3 playbook [1] for
python-tempestconf project even when admin credentials are sourced. It
happens so when python-tempestconf tries to send a POST request and it
happens using devstack [2] and packstack [3] environment as well.
Also I installed environments manually but I wasn't able to reproduce the

I've tried to run openstack commands (openstack user create, ...) in
ansible shell module but they haven't worked as well. However, they worked
when I used os_* modules.

My guess would be, that environment variables are not set properly, but
according to the printenv command, all required environment variables are
set correctly. Or maybe the POST request is for some reason forbidden in
the environment, ..

Due to the fact, it fails on devstack and packstack with the same error and
not all openstack commands can be run from shell, I think it could be an
environment issue. Have you seen something like that? Any guesses or ideas
why it does happen or what I should try?

Thank you very much for any help.

[1] https://review.openstack.org/#/c/513330/

Martin Kopec
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20171127/f9f28d7d/attachment.html>

More information about the OpenStack-dev mailing list