[openstack-dev] [Congress] Run unit test

Ruben r.manganiello1 at studenti.unisa.it
Tue Nov 8 10:08:32 UTC 2016

Hi everybody,
I've been able to restart the congress server, add the driver for magnum and create a datasource.
Now, how can I run the unit test for this driver? Which steps have I to do?


----- Messaggio originale -----
Da: "Ruben" <r.manganiello1 at studenti.unisa.it>
A: "Eric" <ekcs.openstack at gmail.com>
Cc: openstack-dev at lists.openstack.org
Inviato: Domenica, 6 novembre 2016 17:48:24
Oggetto: Re: [openstack-dev] [Congress] Restart Congress server

Hi Eric,
also with the old congress.conf file there is the error.
I've used devstack with a single-process congress deployment.

To stop the congress server I make: screen -x stack and Ctrl-C in the congress window.
To restart the congress server I make: screen -x stack and sudo /usr/local/bin/congress-server --debug in the congress window.

Is it possible that I should rejoin the stack?


----- Original Message -----
From: "Eric" <ekcs.openstack at gmail.com>
To: openstack-dev at lists.openstack.org
Cc: "Ruben" <r.manganiello1 at studenti.unisa.it>
Sent: Friday, November 4, 2016 7:23:50 PM
Subject: Re: [Congress] Restart Congress server

Hi Ruben,

Awesome to hear about your progress!

The error seems to be independent of adding a new driver.

Could you try using the unchanged congress.conf and restarting again to
see if the same problem shows up?

Also, could you give the command you¹re using the launch congress-server?

Mainly I want to understand whether you¹re using single-process congress
deployment or multi-process congress deployment. If multi-process, it¹s
possible that the datasources process was stopped but wasn¹t restarted.

If your screen listing (access by pressing Ctrl-A followed by ") shows
three congress windows like this, then you¹re running in multi-process
29 congress-api    
  30 congress-engine
  31 congress-datasources

To launch Congress, make sure all three are running properly.

A simpler alternative (but takes some time) is to deploy devstack from
scratch (saving your work somewhere of course) using the latest versions
(defaults to single process), which should reduce complications from
multiple processes and make everything easier for dev-testing.

All the best!

On 11/4/16, 4:53 AM, "Ruben" <r.manganiello1 at studenti.unisa.it> wrote:

>Hi everyone,
>I've tried to write a datasource driver for Magnum and the unit test for
>So I've add this datasource driver in
>/opt/stack/congress/congress/datasources/ and the unit test in
>/opt/stack/congress/congress/tests/datasources/ to test it.
>Moreover, I've add the driver to /etc/congress/congress.conf, but when I
>try to restart Congress server I've some errors.
>"2016-11-04 12:13:00.390 TRACE congress.service     self.service_id,
>service, table)
>2016-11-04 12:13:00.390 TRACE congress.service   File
>"/opt/stack/congress/congress/dse2/dse_node.py", line 468, in
>2016-11-04 12:13:00.390 TRACE congress.service     {'table': table})
>2016-11-04 12:13:00.390 TRACE congress.service   File
>"/opt/stack/congress/congress/dse2/dse_node.py", line 355, in
>2016-11-04 12:13:00.390 TRACE congress.service     raise
>exception.NotFound(msg % service_id)
>2016-11-04 12:13:00.390 TRACE congress.service NotFound: service 'nova'
>could not be found
>2016-11-04 12:13:00.390 TRACE congress.service
>2016-11-04 12:13:00.537 DEBUG oslo_concurrency.lockutils [-] Acquired
>semaphore "singleton_lock" from (pid=24411) lock
>2016-11-04 12:13:00.538 DEBUG oslo_concurrency.lockutils [-] Releasing
>semaphore "singleton_lock" from (pid=24411) lock
>I don't know what to do to solve it and even if the driver I've written
>Maybe I make mistakes when I restart Congress server..
>What should I do to restart Congress server?
>What could I do to test the datasource and solve these problems?

OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-request at lists.openstack.org?subject:unsubscribe

More information about the OpenStack-dev mailing list