[openstack-dev] [glance][pbr][requirements] Broken requirements?

Andreas Jaeger aj at suse.com
Mon Mar 23 14:07:26 UTC 2015

On 03/23/2015 02:12 PM, Doug Hellmann wrote:
> Excerpts from Andreas Jaeger's message of 2015-03-23 13:16:05 +0100:
>> The translation jobs [1] are failing since a requirements job merged [2]
>> with:
>>      error in setup command: 'install_requires' must be a string or list
>> of strings containing valid project/version requirement specifiers
>> requirements.txt now contains "oslo.policy~=0.3.1 # Apache-2.0".
>> Is this requirements line wrong - or is pbr broken?
>> Interesting that gate-glance-requirements [3] was successful, I would
>> have expected it to fail since global requirements file contains
>> "oslo.policy>=0.3.1,<0.4.0"
>> What is the proper solution to fix this?
>> I'll send a patch now for fixing the requirements in glance but I wonder
>> whether anything else needs to be done,
> Some of the test nodes apparently have older versions of setuptools that
> don't understand the ~= syntax. We pushed through a patch last week to
> change to the older syntax for expressing the compatible range using >=
> and <. Updating your requirements file to match that should fix the
> problem.

Yes, thanks.

I discussed with Sean on infra channel and the requirements sync failed 
due to the usage of ~= - so, we need to sync manually: 

  Andreas Jaeger aj@{suse.com,opensuse.org} Twitter/Identica: jaegerandi
   SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg, Germany
    GF: Felix Imendörffer, Jane Smithard, Jennifer Guild, Dilip Upmanyu,
        Graham Norton, HRB 21284 (AG Nürnberg)
     GPG fingerprint = 93A3 365E CE47 B889 DF7F  FED1 389A 563C C272 A126

More information about the OpenStack-dev mailing list