[openstack-dev] devstack: Unable to restart rabbitmq-server

John Eckersberg jeckersb at redhat.com
Mon Mar 17 13:19:03 UTC 2014

Deepak C Shetty <deepakcs at redhat.com> writes:
> Hi List,
>      It been few hours and I tried everything from ensuring /etc/hosts, 
> /etc/hostname etc (per google results) and rabbitmq-server still doesn't 
> start. I am using latest devstack as of today on F20

There are a couple of known bugs that can prevent rabbitmq-server from
starting on F20.

First one (same bug, two BZs) is related to SELinux and port probing:

Second one is a race condition in Erlang.  If you are repeatedly unable
to start rabbitmq-server, it's probably not this bug:

I have a patched rabbitmq-server package which includes the fixes for
these two issues, if you'd like to try it and see if it helps your
issue.  And if it helps, please comment on the bug(s) to encourage the
maintainer to pull them into the package :)


Hope that helps,

More information about the OpenStack-dev mailing list