[openstack-dev] devstack: Unable to restart rabbitmq-server

Kashyap Chamarthy kchamart at redhat.com
Mon Mar 17 09:31:42 UTC 2014

On Mon, Mar 17, 2014 at 02:27:29PM +0530, Deepak C Shetty wrote:
> Hi List,
>     It been few hours and I tried everything from ensuring
> /etc/hosts, /etc/hostname etc (per google results) and
> rabbitmq-server still doesn't start. I am using latest devstack as
> of today on F20
> Below is the error I see
> [stack at devstack-vm ~]$ sudo systemctl status rabbitmq-server.service
> rabbitmq-server.service - RabbitMQ broker
>    Loaded: loaded (/usr/lib/systemd/system/rabbitmq-server.service;
> disabled)
>    Active: failed (Result: timeout) since Mon 2014-03-17 07:20:47
> UTC; 14s ago
>   Process: 30065 ExecStopPost=/usr/bin/rm /var/run/rabbitmq/pid
> (code=exited, status=0/SUCCESS)
>   Process: 30027 ExecStop=/usr/lib/rabbitmq/bin/rabbitmqctl stop
> (code=exited, status=0/SUCCESS)
>   Process: 29879 ExecStart=/usr/lib/rabbitmq/bin/rabbitmq-server
> (code=killed, signal=TERM)
>  Main PID: 29879 (code=killed, signal=TERM)
>    CGroup: /system.slice/rabbitmq-server.service

I don't know much about RabbitMQ itself, but a few things that may give
you some debugging clues from systemd journal (look up the man page for
what the switches mean):

Show all logs of priority "error":

    $ journalctl -p err

Some variations:

    $ journalctl /usr/sbin/rabbitmq-server
    $ journalctl -u rabbitmq-server -l -p err
    $ journalctl -u rabbitmq-server -l --since=yesterday -p err


More information about the OpenStack-dev mailing list