[openstack-dev] Neutron: Need help with tox failure in VPN code

Nachi Ueno nachi at ntti3.com
Tue Mar 4 05:41:35 UTC 2014

./run_test.sh or ./run_test.sh -d package_name is working?

2014-03-03 21:28 GMT-08:00 Paul Michali <pcm at cisco.com>:
> Hi,
> I'm stuck and can use some guidance here...please!
> I have a change set out for review that used the VPN Service Type Framework
> ( https://review.openstack.org/74144). Everything worked fine, passed
> Jenkins, etc.
> Found out that the STF won't make it to I-3, so I removed the dependency
> from my change set and tried to modify the plugin.py file to use some STF
> logic (like LBaaS uses) to load the desired service driver that is specified
> as the default. Adjusted the code to no longer use provider info.
> Well, in doing so, tox fails, and unfortunately there little info on the
> failure. This can be seen by running a subset of the tests, where 2 fail:
> tox -e py27 -v -- neutron.tests.unit.services.vpn
> only the name of a failing test case for one, and a mention of return code
> 10 on another and no other info on the failure reason. I didn't see this on
> a full tox run in my repo, but Jenkins failed and Akihiro noticed it too, in
> running the above subset of the suite (thanks!).
> I've narrow it down a bit, but have no idea why it fails...
> One, it seems to be some interaction between test_vpnaas_driver_plugin.py
> and the two service driver tests (cisco_ipsec.py and ipsec.py). I can remove
> either one of the service driver tests cases, and it will still fail with
> the other one (so even the reference code fails).
> Two, if I change plugin.py to set self.driver to the reference device driver
> (as is done in the latest patch set) it works fine with all test cases.
> Three, it seems to be a test only issue, because I can run devstack with the
> login I have in plugin.py, currently commented out in __init__(), and
> successfully load either the reference or cisco service driver, by changing
> neutron.conf.
> It seems like I'm doing something wrong in the loading of the service
> driver, or using this implementation, is somehow interacting with the tests.
> If anyone has ideas on what is wrong, or a better way to load the service
> driver, please let me know. I was thinking I could read and parse
> neutron.conf manually and then load the service driver, but there must be a
> better way!
> Thanks!
> PCM (Paul Michali)
> MAIL          pcm at cisco.com
> IRC            pcm_  (irc.freenode.net)
> TW            @pmichali
> GPG key    4525ECC253E31A83
> Fingerprint 307A 96BB 1A4C D2C7 931D 8D2D 4525 ECC2 53E3 1A83
> _______________________________________________
> OpenStack-dev mailing list
> OpenStack-dev at lists.openstack.org
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

More information about the OpenStack-dev mailing list