[openstack-dev] [DevStack] fails in lxc running ubuntu trusty amd64

Mike Spreitzer mspreitz at us.ibm.com
Thu Jun 19 14:07:03 UTC 2014

Sean Dague <sean at dague.net> wrote on 06/19/2014 06:43:36 AM:

> On 06/19/2014 03:03 AM, Mike Spreitzer wrote:
> > In my linux containers running Ubuntu 14.04 64-bit, DevStack fails
> > because it can not install the package named tgt.  The problem is that
> > the install script invokes the tgt service's start operation, which
> > launches the daemon (tgtd), and the launch fails with troubles with
> > RDMA.  Has anybody tried such a thing?  Any fixes, workarounds?  Any 
> My understanding is that's basically the blocker to running devstack
> inside a container, whatever does iscsi fails in that environment.
> I do not yet know anyone that's solved this. I'd be super happy if
> someone did. I'd love to be running devstack on my desktop in a 

Well, since iSCSI and RDMA are not going to work anyway (my only use for 
this host is running DevStack inside jails), would a possible work-around 
be to disable iSCSI/RDMA/whatever-rattles-those-cages deeply in the host's 
kernel?  I do not know how to do that, but would be happy to give it a try 
if I could get a pointer on how to do that.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20140619/78df2c91/attachment.html>

More information about the OpenStack-dev mailing list