[openstack-dev] [DevStack] fails in lxc running ubuntu trusty amd64

Sean Dague sean at dague.net
Thu Jun 19 10:43:36 UTC 2014

On 06/19/2014 03:03 AM, Mike Spreitzer wrote:
> In my linux containers running Ubuntu 14.04 64-bit, DevStack fails
> because it can not install the package named tgt.  The problem is that
> the install script invokes the tgt service's start operation, which
> launches the daemon (tgtd), and the launch fails with troubles with
> RDMA.  Has anybody tried such a thing?  Any fixes, workarounds?  Any ideas?

My understanding is that's basically the blocker to running devstack
inside a container, whatever does iscsi fails in that environment.

I do not yet know anyone that's solved this. I'd be super happy if
someone did. I'd love to be running devstack on my desktop in a container.

If you completely disable cinder it might work. However that's not a
service collection that's really tested by anyone right now, so I expect
that will expose more issues.


Sean Dague

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 482 bytes
Desc: OpenPGP digital signature
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20140619/379bffa4/attachment.pgp>

More information about the OpenStack-dev mailing list