[openstack-dev] [heat] "heat.conf.sample is not up to date"

Mike Spreitzer mspreitz at us.ibm.com
Mon Aug 25 04:22:35 UTC 2014

Ruslan Kamaldinov <rkamaldinov at mirantis.com> wrote on 08/24/2014 12:30:04 

> From: Ruslan Kamaldinov <rkamaldinov at mirantis.com>
> To: "OpenStack Development Mailing List (not for usage questions)" 
> <openstack-dev at lists.openstack.org>, 
> Date: 08/24/2014 12:32 PM
> Subject: Re: [openstack-dev] [heat] "heat.conf.sample is not up to date"
> On Sun, Aug 24, 2014 at 11:10 AM, Mike Spreitzer <mspreitz at us.ibm.com> 
> > What I really need to know is what to do when committing a change that
> > really does require a change in the sample configuration file.  Of 
course I
> > tried running generate_sample.sh, but `tox -epep8` still complains. 
What is
> > the right procedure to get a correct sample committed?  BTW, I am 
doing the
> > following admittedly risky thing: I run DevStack, and make my changes 
> > /opt/stack/heat/.
> Mike,
> It seems that you have oslo.messaging installed from master (default
> behavior of Devstack), while heat.sample.config is built for
> oslo.messaging v 1.3.1. As a quick workaround I'd suggest to downgrade
> oslo.messaging to 1.3.1 in pep8 virtual environment:
> $ cd /opt/stack/heat
> $ source .tox/pep8/bin/activate
> $ pip install oslo.messaging==1.3.1
> $ deactivate
> $ tox -e pep8 # should pass now

In that same VM in which I ran DevStack, I also made an independent clone 
of heat in ~/code/heat; my original email quoted a failure from that 
clone, hoping that it might be easier to debug (being a simpler scenario). 

 Below is a typescript showing me try again there, including a trial of 
what Mathieu Gagné suggested (which has some kind of command line syntax 

error, and did nothing).  You will see that I investigated and found that 
in this case tox's venv contained oslo.messaging version 1.3.1, so no 
adjustment about that was needed.  Yet it still failed.

ubuntu at mjs-dstk-821a:~/code/heat$ rm -rf .tox

ubuntu at mjs-dstk-821a:~/code/heat$ tox -evenv bash 
./tools/config/generate_sample.sh -b . -p heat -o etc/heat
usage: tox [-h] [--version] [-v] [--showconfig] [-l] [-c CONFIGFILE]
           [-e envlist] [--notest] [--sdistonly] [--installpkg PATH]
           [--develop] [--set-home] [-i URL] [-r] [--result-json PATH]
           [--hashseed SEED] [--force-dep REQ] [--sitepackages]
           [args [args ...]]
tox: error: unrecognized arguments: -b . -p heat -o etc/heat

ubuntu at mjs-dstk-821a:~/code/heat$ tox -epep8
pep8 create: /home/ubuntu/code/heat/.tox/pep8
pep8 installdeps: -r/home/ubuntu/code/heat/requirements.txt, 
pep8 develop-inst: /home/ubuntu/code/heat
pep8 runtests: PYTHONHASHSEED='0'
pep8 runtests: commands[0] | flake8 heat bin/heat-api bin/heat-api-cfn 
bin/heat-api-cloudwatch bin/heat-engine bin/heat-manage contrib
pep8 runtests: commands[1] | 
--- /tmp/heat.UnHAZD/heat.conf.sample   2014-08-25 04:06:07.648849999 
+++ etc/heat/heat.conf.sample   2014-08-24 06:53:51.540849999 +0000
@@ -159,10 +159,6 @@
 # Size of RPC connection pool. (integer value)
-# Modules of exceptions that are permitted to be recreated
-# upon receiving exception data from an rpc call. (list value)
 # Qpid broker hostname. (string value)
@@ -301,15 +297,6 @@
 # Heartbeat time-to-live. (integer value)
-# Host to locate redis. (string value)
-# Use this port to connect to redis host. (integer value)
-# Password for Redis server (optional). (string value)
 # Size of RPC greenthread pool. (integer value)
@@ -1229,6 +1216,22 @@
+# Options defined in oslo.messaging
+# Host to locate redis. (string value)
+# Use this port to connect to redis host. (integer value)
+# Password for Redis server (optional). (string value)
check_uptodate.sh: heat.conf.sample is not up to date.
check_uptodate.sh: Please run 
ERROR: InvocationError: 
pep8 runtests: commands[2] | 
/home/ubuntu/code/heat/tools/requirements_style_check.sh requirements.txt 
pep8 runtests: commands[3] | bash -c find heat -type f -regex '.*\.pot?' 
-print0|xargs -0 -n 1 msgfmt --check-format -o /dev/null
__________ summary 
ERROR:   pep8: commands failed

ubuntu at mjs-dstk-821a:~/code/heat$ . .tox/pep8/bin/activate

(pep8)ubuntu at mjs-dstk-821a:~/code/heat$ python
Python 2.7.6 (default, Mar 22 2014, 22:59:56) 
[GCC 4.8.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> system
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
NameError: name 'system' is not defined
>>> import sys
>>> print sys.path
['', '/home/ubuntu/code/heat', 
'/usr/lib/python2.7', '/usr/lib/python2.7/plat-x86_64-linux-gnu', 

(pep8)ubuntu at mjs-dstk-821a:~/code/heat$ find .tox/pep8 -name "*messaging*"
(pep8)ubuntu at mjs-dstk-821a:~/code/heat$ 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20140825/4de4c724/attachment.html>

More information about the OpenStack-dev mailing list