[Openstack-operators] [nova] instance partition size discrepancy

Carlos Konstanski ckonstanski at pippiandcarlos.com
Wed Apr 26 12:59:48 UTC 2017

I'll check the image for these tools. I should have mentioned that the
behavior is intermittent. Sometimes it does the right thing.

At first I thought I could choose "manual" partitioning when creating
the instance. But that turned out to have no effect. It worked the first
time, but I think it was just a coincidence. In reality, about one in
every three instance creations works and the other two don't.

Next time I reproduce the issue I will try resize2fs. Thanks for that.


Tomáš Vondra <vondra at homeatcloud.cz> writes:

> Have you tried
> # resize2fs /dev/vda
> ?
> Alternatively, if you use images with cloud-init and
> initramfs-growroot installed, it should work out of the box.
> Tomas
> -----Original Message-----
> From: Carlos Konstanski [mailto:ckonstanski at pippiandcarlos.com] 
> Sent: Wednesday, April 26, 2017 12:02 AM
> To: openstack-operators at lists.openstack.org
> Subject: [Openstack-operators] [nova] instance partition size discrepancy
> I'm having an issue where the instance thinks its root filesystem is
> much smaller than the size of the volume that I used to create it. Not
> only that, the OS cannot decide on whether it thinks the size is right
> or wrong.
> See the following pastebin:
> https://paste.pound-python.org/show/eNt8nLNLhHAL5OYICqbs/
> Notice that everything shows the size as 20 GB except df, which shows
> it as 2.8 GB. I ran the previous instance out of space before spinning
> up this new one, so 2.8 seems to be the winner (though wrong).
> Figured I'd check to see if this is a known issue while I dig deeper.
> Carlos Konstanski
> _______________________________________________
> OpenStack-operators mailing list
> OpenStack-operators at lists.openstack.org
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-operators

More information about the OpenStack-operators mailing list