[Openstack-operators] [nova] instance partition size discrepancy

Tomáš Vondra vondra at homeatcloud.cz
Wed Apr 26 09:25:01 UTC 2017

Have you tried
# resize2fs /dev/vda
Alternatively, if you use images with cloud-init and initramfs-growroot installed, it should work out of the box.

-----Original Message-----
From: Carlos Konstanski [mailto:ckonstanski at pippiandcarlos.com] 
Sent: Wednesday, April 26, 2017 12:02 AM
To: openstack-operators at lists.openstack.org
Subject: [Openstack-operators] [nova] instance partition size discrepancy

I'm having an issue where the instance thinks its root filesystem is much smaller than the size of the volume that I used to create it. Not only that, the OS cannot decide on whether it thinks the size is right or wrong.

See the following pastebin:

Notice that everything shows the size as 20 GB except df, which shows it as 2.8 GB. I ran the previous instance out of space before spinning up this new one, so 2.8 seems to be the winner (though wrong).

Figured I'd check to see if this is a known issue while I dig deeper.

Carlos Konstanski

OpenStack-operators mailing list
OpenStack-operators at lists.openstack.org

More information about the OpenStack-operators mailing list