[Openstack-operators] nova add-floating-ip fails

mpedersen at choopa.com mpedersen at choopa.com
Thu May 10 18:57:42 UTC 2012

Sorry Kevin, only sent to you. Re-sending to the list.

On Thu, 10 May 2012 11:49:13 -0700, "Fox, Kevin M" <kevin.fox at pnnl.gov>
> It may not be relevant here, but I ran into a problem where I had two
> nova-network services running on two different boxes and it had a
> affect. Things mostly worked except the floating-ip stuff only sometimes
> worked.
In this case, it's only one machine, so that's not it.

It's also 100% reproducible. If I use the web interface, then it works. If
I use the command line, it doesn't.

To be fair, it's a little more precise than that, and might have something
specific to do with my configuration (and I don't even know it). When I go
through the web, I notice that "nova-manage floating list" shows all
allocated IPs as belonging to the demo project. When I use the command
line, they belong to the admin project. Not sure if that helps at all.

More information about the Openstack-operators mailing list