[requirements][FFE][congress] remove psycopg2>=2.7

Alex Schultz aschultz at redhat.com
Thu Apr 4 14:32:56 UTC 2019

On Thu, Apr 4, 2019 at 7:58 AM Matthew Thode <mthode at mthode.org> wrote:
> On 19-04-04 01:20:18, Eric K wrote:
> > Requesting exception to remove a requirement to resolve a packaging issue.
> >
> > The package is needed only for an experimental feature, but causes
> > packaging issue on RHEL/CentOS 7. Propose to remove from requirements and
> > require manual install to enable the experimental feature.
> >
> > https://review.openstack.org/#/c/649772/
> >
> I imagine psycopg2 is one of many dependencies that are not fully
> compliant with our upper-constraints (and probably a bunch of projects
> global-constraints).  Is it possible to lower the version required (be
> compatible with 2.6 or whatever is in centos)?  The requirements project
> itself sets no lower bound for psycopg2.

Centos7 has 2.5. I had asked about getting 2.7 in RDO but if it's
optional it would be nice for it not to be included by default. We hit
the issue in puppet-congress so we disabled out actual test jobs[0]
because congress currently doesn't work on ubuntu[1] and was broken on
centos[2] by this new requirement.

[0] https://review.openstack.org/#/c/649439/
[1] http://logs.openstack.org/33/647333/1/check/puppet-openstack-beaker-ubuntu-bionic/2cfe5a4/job-output.txt.gz#_2019-04-02_10_48_17_614150
[2] http://logs.openstack.org/33/647333/1/check/puppet-openstack-beaker-centos-7/c10fb99/logs/syslog.txt.gz#_Apr_02_10_47_47

> --
> Matthew Thode

More information about the openstack-discuss mailing list