[openstack-dev] [TripleO][Kolla] default docker storage backend for TripleO

Steve Baker sbaker at redhat.com
Thu May 18 02:30:46 UTC 2017

On Thu, May 18, 2017 at 12:38 PM, Fox, Kevin M <Kevin.Fox at pnnl.gov> wrote:

> I've only used btrfs and devicemapper on el7. btrfs has worked well.
> devicemapper ate may data on multiple occasions. Is redhat supporting
> overlay in the el7 kernels now?

overlay2 is documented as a Technology Preview graph driver in the Atomic
Host 7.3.4 release notes:

> _____________________________
> From: Dan Prince [dprince at redhat.com]
> Sent: Wednesday, May 17, 2017 5:24 PM
> To: openstack-dev
> Subject: [openstack-dev] [TripleO][Kolla] default docker storage backend
> for    TripleO
> TripleO currently uses the default "loopback" docker storage device.
> This is not recommended for production (see 'docker info').
> We've been poking around with docker storage backends in TripleO for
> almost 2 months now here:
>  https://review.openstack.org/#/c/451916/
> For TripleO there are a couple of considerations:
>  - we intend to support in place upgrades from baremetal to containers
>  - when doing in place upgrades re-partitioning disks is hard, if not
> impossible. This makes using devicemapper hard.
>  - we'd like to to use a docker storage backend that is production
> ready.
>  - our target OS is latest Centos/RHEL 7
> As we approach pike 2 I'm keen to move towards a more production docker
> storage backend. Is there consensus that 'overlay2' is a reasonable
> approach to this? Or is it too early to use that with the combinations
> above?
> Looking around at what is recommended in other projects it seems to be
> a mix as well from devicemapper to btrfs.
> [1] https://docs.openshift.com/container-platform/3.3/install_config/in
> stall/host_preparation.html#configuring-docker-storage
> [2] http://git.openstack.org/cgit/openstack/kolla/tree/tools/setup_RedH
> at.sh#n30
I'd love to be able to use overlay2. I've CCed Daniel Walsh with the hope
we can get a general overview of the maturity of overlay2 on rhel/centos.

I tried using overlay2 recently to create an undercloud and hit an issue
doing a "cp -a *" on deleted files. This was with kernel-3.10.0-514.16.1
and docker-1.12.6.

I want to get to the bottom of it so I'll reproduce and raise a bug as
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20170518/cffeb663/attachment.html>

More information about the OpenStack-dev mailing list