[openstack-dev] [all] PBR 2.0.0 release *may* cause gate failures

Andreas Jaeger aj at suse.com
Wed Mar 1 18:50:51 UTC 2017

On 2017-03-01 17:13, Doug Hellmann  wrote:
> Excerpts from Andreas Jaeger's message of 2017-03-01 16:22:24 +0100:
>> On 2017-03-01 06:26, Tony Breeds  wrote:
>>> Hi All,
>>>     Earlier today the release team tagged PBR 2.0.0.  The reason for the major
>>> version bump is because warnerrors has been removed in favor of
>>> warning-is-error from sphinx >= 1.5.0.
>> Can we change the sphinx==1.3.6 line in upper-constraints now?
> We're currently running into failures updating requirements because of
> the pbr cap in several libraries.
> I see requestsexceptions, sqlalchemy-migrate, yaql, fairy-slipper,
> pypowervm, gnocchiclient, reno, and aodhclient mentioned in
> http://logs.openstack.org/88/439588/2/check/gate-requirements-tox-py27-check-uc-ubuntu-xenial/97625f3/console.html
> for example.
> I'm working on reno right now.


fairy-slipper is retired, let's remove it -

 Andreas Jaeger aj@{suse.com,opensuse.org} Twitter: jaegerandi
  SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg, Germany
   GF: Felix Imendörffer, Jane Smithard, Graham Norton,
       HRB 21284 (AG Nürnberg)
    GPG fingerprint = 93A3 365E CE47 B889 DF7F  FED1 389A 563C C272 A126

More information about the OpenStack-dev mailing list