[openstack-dev] [osc][openstackclient][zun] Collision on the keyword 'container'

Hongbin Lu hongbin.lu at huawei.com
Tue Dec 20 22:22:05 UTC 2016

From: Steve Martinelli [mailto:s.martinelli at gmail.com]
Sent: December-20-16 5:09 PM
To: OpenStack Development Mailing List (not for usage questions)
Subject: Re: [openstack-dev] [osc][openstackclient][zun] Collision on the keyword 'container'

On Tue, Dec 20, 2016 at 4:39 PM, Clay Gerrard <clay.gerrard at gmail.com<mailto:clay.gerrard at gmail.com>> wrote:

On Tue, Dec 20, 2016 at 1:00 PM, Hongbin Lu <hongbin.lu at huawei.com<mailto:hongbin.lu at huawei.com>> wrote:

$ openstack objectstore container <action> <args>
$ openstack container container <action> <args>
$ openstack secret container <action> <args>


This is the closest thing I can see that's somewhat reasonable - with the obvious exception of "container container <action>" - which is pretty gross.

Here's the best list I could find of what's going on now:


The collision of top-level resource names is not new.  You see stuff like "volume create" & "server create" - but also "volume backup create" & "server backup create"- which is an obvious pattern to replicate for disambiguating top level name conflicts with similarly named (sub?)-resources between services - except apparently in an effort to keep things flat no one saw it coming with a name like "container".

But IMHO an object-store "container" is not a top level OpenStack resource, is it?  I would think users would be happy to dump stuff into the object store using "object create" - and reasonably expect to use "object container create" to create a container *for their objects*?  This isn't a generic OpenStack "container" - you can't use this generic "container" for anything except objects?  Oddly, this pattern is already in use with the pre-existing "object store account" command?!

This was my initial thought when discussing the problem with Hongbin last night.

We have three main "swift" resources in OSC -- "object store account", "container" and "object". I think renaming "container" to "object store container" is totally acceptable. The issue of deprecation comes into play, we'll need to deprecate it and give it at least one cycle. Luckily, the zun team isn't ready to publish a CLI just yet.

Alternatively, I don't mind "appcontainer".

[Hongbin Lu] I am going to propose ‘appcontainer’ to Zun team. It looks like a good alternative to me.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20161220/5c3faa47/attachment.html>

More information about the OpenStack-dev mailing list