[openstack-dev] [ironic][OpenStackClient] two openstack commands for the same operation?

Loo, Ruby ruby.loo at intel.com
Mon Aug 29 19:02:46 UTC 2016


Thanks for everyone's comments. Dean's were very useful, I'm going to file those away for future commands.

In this case, I think we'll go with 'passthru' since I do want to make life easier for the operators :)


On 2016-08-29, 12:00 PM, "Jay Faulkner" <jay at jvf.cc<mailto:jay at jvf.cc>> wrote:

On Aug 29, 2016, at 8:19 AM, Dean Troyer <dtroyer at gmail.com<mailto:dtroyer at gmail.com>> wrote:

On Mon, Aug 29, 2016 at 9:41 AM, Loo, Ruby <ruby.loo at intel.com<mailto:ruby.loo at intel.com>> wrote:
I did this because 'passthrough' is more English than 'passthru' and I thought that was the 'way to go' in osc. But some folks wanted it to be 'passthru' because in ironic, we've been calling them 'passthru' since day 2.

Our default rule is to use proper spellings and not abbreviations[0].  The exceptions we have made are due to either a) significant existing practice in the industry (outside OpenStack, mostly in the network area so far); and b) when the user experience is clearly improved.

To be clear; thru is a valid english word, in just about every dictionary I've checked. In fact, some evidence shows it predates "through" as a word. I agree with other folks who have posted on the mailing list that keeping "passthru" is going to be more clear to operators of ironic than changing it to "passthrough" in this single context.

Jay Faulkner

You might notice that calling out prior OpenStack usage is absent from that list.  One of the tenets of OSC from the start is to look first at user experience and identifying a _single_ set of terminology.  An existing practice can fall under (b) when it is compelling overall, and is an easier case to make when there is no competing OSC usage, or other OSC usage matches.

Unfortunately, I wasn't able to make everyone happy because someone else thinks that we shouldn't be providing two different openstack commands that provide the same functionality. (They're fine with either one, just not both.)

I agree with not aliasing commands out of the box.  We'll do that for deprecations, and are looking at a generalize alias method for other reasons, but on initial implementation I would prefer to not do this.

What do the rest of the folks think? Some guidance from the OpenStackClient folks would be greatly appreciated.

I would suggest you pick the one that lines up with usage outside OpenStack, in the sorts of ways that our users would be familiar with[1].  In this case, a grep of help output of even 'passthr' will find the match.

Hopefully this all makes enough sense that we can add it as a guideline to the OSC docs.  Feedback welcome.


[0] Where 'proper' is usually North American English, for whatever definition of that we have. This is totally due to me not thinking far enough ahead 4 years ago...

[1] Cases like "all other clouds use this term" or "it is the common way to refer to this resource in the networking field" have been used in the past.

Dean Troyer
dtroyer at gmail.com<mailto:dtroyer at gmail.com>
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: OpenStack-dev-request at lists.openstack.org<mailto:OpenStack-dev-request at lists.openstack.org>?subject:unsubscribe

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20160829/4402fe83/attachment.html>

More information about the OpenStack-dev mailing list