[openstack-dev] [Rally] Term "workload" has two clashing meanings

Aleksandr Maretskiy amaretskiy at mirantis.com
Mon Apr 11 15:38:25 UTC 2016

Hi all,

this is about terminology, we have term "workload" in Rally that appears in
two clashing meanings:

 1. module rally.plugins.workload
which collects plugins for cross-VM testing
 2. workload replaces term "scenario" in our new input task format
(task->scenarios is replaced with task->subtasks->workloads)

Let's introduce new term as replacement of "1." (or maybe "2." but I
suppose this is not the best option).

Maybe rename rally.plugins.workload to:
*vmload   *rally.plugins.*vmperf*
   ...more ideas?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20160411/d5083a5a/attachment.html>

More information about the OpenStack-dev mailing list