[openstack-dev] [Rally] Term "workload" has two clashing meanings

Roman Vasilets rvasilets at mirantis.com
Mon Apr 11 18:10:44 UTC 2016

Hi all, personally I want to suggest* crossload. *Concept is similar to
cross training(training in two or more sports in order to improve fitness
and performance, especially in a main sport.) in sport. By that template -
crossload is load in two or more areas in order to improve durability and
performance, especially in a main area.
Thanks, Roman.

On Mon, Apr 11, 2016 at 6:38 PM, Aleksandr Maretskiy <
amaretskiy at mirantis.com> wrote:

> Hi all,
> this is about terminology, we have term "workload" in Rally that appears
> in two clashing meanings:
>  1. module rally.plugins.workload
> <https://github.com/openstack/rally/tree/master/rally/plugins/workload>
> which collects plugins for cross-VM testing
>  2. workload replaces term "scenario" in our new input task format
> <https://github.com/openstack/rally/blob/master/doc/specs/in-progress/new_rally_input_task_format.rst>
> (task->scenarios is replaced with task->subtasks->workloads)
> Let's introduce new term as replacement of "1." (or maybe "2." but I
> suppose this is not the best option).
> Maybe rename rally.plugins.workload to:
>    rally.plugins.
> *vmload   *rally.plugins.*vmperf*
>    rally.plugins.*shaker*
>    rally.plugins.*vmworkload*
>    ...more ideas?
> __________________________________________________________________________
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: OpenStack-dev-request at lists.openstack.org?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-dev/attachments/20160411/6990fee5/attachment.html>

More information about the OpenStack-dev mailing list